当前位置:首页 > Linux
使用 yum 对已安装的软件进行降级
来源:靑龍一笑的博客  作者:靑龍一笑  发布时间:2022-08-09 14:27:17  点击量:276  评论:0

    有时候,在使用 yum 将软件包升级到最新版本后,发现其它软件无法正常安装。例如,将 glibc 升级到 2.17-326.el7_9,结果 gcc 所需要的却是 2.17-325.el7_9 版本的 glibc。此时,需要对 glibc 进行降级安装。
    查看 glibc 版本信息:

[root@CentOS7 softwares]# rpm -qa | grep glibc
glibc-2.17-326.el7_9.x86_64
glibc-common-2.17-326.el7_9.x86_64

    降级安装 glibc:

[root@CentOS7 softwares]# yum downgrade glibc-2.17-325.el7_9 glibc-common-2.17-325.el7_9 -y

    查看安装后的 glibc 版本信息:

[root@CentOS7 softwares]# rpm -qa | grep glibc
glibc-common-2.17-325.el7_9.x86_64
glibc-2.17-325.el7_9.x86_64

    此时,可以正常安装 gcc 了:

[root@CentOS7 softwares]# yum install gcc gcc-c++ -y
版权所有 © 2005-2023 靑龍一笑的博客  Powered by C.S.Ricen
Copyright © 2005-2023 by www.ricensoftwares.com.cn  All Rights Reserved.

欢迎光临本站,这里是靑龍一笑的博客。

因资金匮乏,本站已迁到国外的免费空间,可能导致本站的访问速度较慢,由此给您带来的不便,敬请谅解。

您可以通过下方的“支持本站建设”链接,给本站提供资金支持。

Free Web Hosting